fable 3 silver keys + guest glitch

hi, i just contacted xbox thru phone and email, and they ain't helping me. they keep saying to come here. i've collected all 50 silver keys and gold keys.  but one of the silver keys isn't listed as collected in mistpeak valley. i even went to a youtube video that shows all the silver keys in mistpeak valley. i've triple checked those three spots.... and it ain't there anymore. it says i have 5 out of 6. now i can't get this achievement, and i have only ONE quest to complete, but i can't seduce this dude in the marriage of inconvenience quest.

 

anyone know how to fix this? if i can't get answers here, i'll contact lionhead studios.

 

Discussion Info


Last updated July 3, 2018 Views 29 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

If you are 100% that you have all the keys then I would go with contacting Lionhead OP. I got this myself with no problems so its not something that requires a patch or anything like that.(At least when I played).

Its definitely worth asking them though.

Have you tried the correct way to seduce veronica?, and it just does not work.

Just a thought, have you definitely got the one in Millfields monorail station, as this is classed as a Mistpeak key

I had the same problem in Mistpeak Valley. And as I remember, the clue was really somewhere in those caves of monorail station. There's a place you have to got a Reaver's key to access, am I right? =)

Paan89 I think the key you are referring to is the Technician's key.

oh.... okay, i got all the keys. the ending of the video, the building looks the same as the hole building. and those two areas should really be connected somehow.... anyone have any advice for the marriage of inconvenience quest?

Have you got both the Lover Expression pack and the Family pack from the Road to Rule ? You need both to be able to propose marriage to someone.

yeah. i've unlocked all the chests on the road to rule.... why? did you finish that quest? i have 300+ guild seals

In order to try and help some more can you tell me how far you can get with this quest.

When you arrive to begin this quest, you'll find a couple arguing. If you're a male Hero, the husband after being kicked out of the house will ask you if you would help him split up with Veronica his wife. When you accept, it turns out the way you go about doing this is to seduce her. After interacting with Veronica and getting her to like you for a bit, she'll want some jewellery. The quest marker will take you to a jewellery stand where you can buy jewellery for a small amount of gold

I just copied that from the fable wiki. thats as far as i got early in the game. before i bought jewerely, i did the A/green button interactions only, cuz thats all it would let me do. i bought a necklace or something, gave it to the person, and now it wants me to seduce this person. but it won't let me.

ALSO:

■If you're having trouble interacting with either the husband or wife you are trying to woo, try buying a wedding ring. It's possible you can't interact because you are missing one of the key ingredients needed to complete the quest.

i tried buying a wedding ring, but didn't do anything.

After giving her the jewellery, that usually takes your relationship from neutral to friends. You then have to carry on doing more positive expressions (A) to take the relationship to lover. (She will have a heart over her head) This is when she will ask you to take her on a date, it is whilst you are on the date you can ask her to marry you.

The above is how it is supposed to pan out, if it will not allow you to take the relationship to lover you will not be able to complete the quest.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.