Fable 3 DLC not downloading correctly/at all.

I have purchased the Fable 3 DLC Understone and also tried to download a few of the free DLC I noticed but I'm not having much luck in getting the content onto my Xbox 360. When I press yes to download it goes to the active downloads screen just fine but the download stays at 1% before quickly saying its all finished. Now I know that I can't possibly be downloading 250ish MB in about 3 seconds so I went to my memory to check if the DLC was there and like I thought, its not. I've tried turning my Xbox off and on again and all that kinda stuff  so I'm just wondering if there is a solution somewhere for this problem because I would really like to play the DLC that I purchased. Thanks.

 

Question Info


Last updated September 9, 2018 Views 6 Applies to:

The reason the DLC downloads so fast is because it was already on the disc itself and you are just unlocking it..

As for the DLC not appearing in the memory section I can only offer something to try.

Clear your HDD cache then try downloading the DLC.

 

(LINK) How to Clear System Cache

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.