Execution problems??

*I have all the requirements met for the executions

*I know that you have to play as the locusts for the arm rip / have the pistol equiped

I am having a bit of trouble performing the executions for the locust's arm rip and the scorcher.  Whenever I do the scorcher execution instead of the one it is supposed to do (scorcher in the belly, fire out the mouth, etc.)  my character instead stomps on the other player's arm and hits them over the head with the weapon.  As for the arm rip the locust always ends up doing the COG face punch.  

I tried deleting my memory cache and re-installing the patch but it didn't help.  Anyone else facing similar issues?


 

Discussion Info


Last updated July 3, 2018 Views 1 Applies to:

Do it in a Private Deathmatch after you unlock the Scorcher one, by HOLDING 'Y' until it fills the circle, and you shouldn't have any problem with it.

.

Same with the arm rip.

.

Don't do it in Beast/whatnot, and you should be fine : )

.

You could try campaign for the Scorcher too, perhaps. Hopefully it works for you :D

I'm not sure why but it's executing the right ones!  I have the 40 out of 40 kills needed and I hold Y until it fills the circle as well.  

.

I've tried botch in Private and public versus matches and the scorcher one in campaign.  The locust will always do the face punch instead of the arm rip and the scorcher will always do a different one as well.  

.

I just recently unlocked the gorgon pistol execution and I noticed that my scorcher execution and my gorgon pistol execution are the same.

.

No clue why.  Anybody know what to do?  Anyone else heard of anyone who has had this problem or has had this problem themselves?

That sounds mad ? i have no idea what thats all about ive noticed in beast mode that my friends will do the arm rip but i always do the COG punch out....................the scorcher doing the gorgon execution sound super strange no idea why its doing do errrrrrm install the game ? recover your gamertag ?

Yeah I have no idea either.  I might try installing the game or recovering my gamertag if I can't come up with anything else.  I appreciate the help guys!  I'm wondering if it could be the disc.  It doesn't seem like many other people are experience this problem...