ESO won't Sync to saved data.

Anyone else having this problem? The game won't sync to my saved data, so it won't let me play my game. This happened after this mornings maintenance. I've searched around the web for a solution to this problem, but can't seem to find anyone else having this issue. If you are having the same issue or know a fix for it, could you please reply? Thanks

 

Discussion Info


Last updated July 4, 2018 Views 31 Applies to:

Ditto here, however I was playing this morning Pacific time zone. AS of now, 6:30 PM, I can not. July 14, 2015

You're not the only one. I've been fighting this for a few hours , now. I've tried multiple reset cycles,  hard resets and deleting local saved data. I'm not sure what else to do.

It is definitely on their end, you have proven that. THEY ARE JUST SLOW IN UPDATING THEIR STATUS FOR US. I'd rather have bad news right away than inaccurate news immediately .

Ok I Thought it was just me,   lets see how long it takes for them to fix it.

Jermaine

I'm going to check every 30 min

Ok, so I figured out its on xbox live end of things. Just checked my Network settings and found that social and gaming are having issues. And referred me to Xbox.com/status    Hope this helps.

Nice detection

Hi Xbox members are you having issues recovering or syncing your saved games? Our team is already investigating this issue and we're trying to get it fixed as soon as we possibly can! Thanks for your patience while we get this worked out. We'll update you when we have more info.

I think IT WORKS NOW !!!!!!

I'M IN