Escalation Map Pack not working..

For some reason, i bought the map pack after i bought the First Strike Maps and its not working or loading properly. First Strike packs are working but the Esclations pack is not. i think it was damage so i tryed to redownloading it (like 5 times) but still no luck.. it appears on my HDD but it doesnt say it got courrpted or damage. any way to fix this problem ? right now im redownloading it through this site.

 

Discussion Info


Last updated July 3, 2018 Views 2 Applies to:

I had the same problem in Halo: Reach. I had the Noble Map pack and couldn't play the Difiant. So I deleted the Noble and it worked. Try to delete the First Strike and be better off with Escalation. Maybe even redownload First Strike after awhile.

when i click play now it says to use this item pay the game it wad dl for

i'm having the same problem!! i can play call of the dead zombies but i get all kinds of glitches...like at level 12 it signs me out of xbox live(i only have free(silver)), and at the same time all the sounds for drops, level start,george, etc disappear. once the zipline sounded like someone was coming down but it wasnt being used(continued like that for quite a while)? and once the zombies spawned real slow 2 -3 at a time and then a rapetrain would come out of nowhere ??.....so far its always the same though....level 12 no sounds except zombies and signed out.....have any luck yet ? got it fixed? and are the glitches the same for you??