Error 0x87de07d1 after purchasing The Swapper, and double-charged

I tried to purchase The Swapper, and was told "something' went wrong and to try again later. I tried again immediately after, I got the confirmation for the charge, it downloaded and installed, but when I try to run it, I get the "Do you own this game or app?" prompt. I rebooted, I logged out and logged in... Then I went to my credit card company's website and I see two pending charges from today for the price of this title.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:
Answer

And the problem went away just as mysteriously. I got home and The Swapper was working, and I was able to download and buy Lifeless Planet without a hitch. Not exactly the most confidence-inspiring series of events...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.