Entered prepaid card, and tried to download

I purchased a prepaid card today, and put the funds into my account.  So I tried 3-4 times to download Mass Effect 3 Citadel pack part one, and selected the added funds from the prepaid card, and there is an error message.  

It gave the error "code" as this:  15A5B118F8D1AF7  It just said code next to the number.

I took a screen shot, but can not post it in this message.

it does not look like my account is charged, but this is annoying.

I used my new debit card last time.  and it was pretty much error free.  The only error was downloading my Fallout New Vegas content, but I figured it out. 

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

If you're using the website to purchase this item then you will not be able to do so using the currency you added as the website has not yet been set up to do this.

Buy the item from the console marketplace.  It will automatically take from your currency first.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.