Downloadable Content: Disc Unreadable Error for Dead Space

Hello, I recently purchased Dead Space off the Market Place. I think I'm on Chapter 4 or 5, and when I got on the tram to the loading screen, my Xbox came up with a "Disc Unreadable" error. I tried deleting the cache to the hard drive, that didn't work. I really don't want to redown load it, but if I have to, I will to make the game work.

If there's anything else I could possibly do without redown loading the game, that would be lovely.

 

Question Info


Last updated July 4, 2018 Views 9 Applies to:

To my knowledge, no, if you already tried deleting your cache, all I know that is left is to re-download it. Even if there are other theories to fix this problem, I imagine re-downloading it is the best first option. I hope it works out.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.