Does anyone know how to actually fix 5 Star Dog Potion?

Ive been reading through forum after forum for about 2 hours now on how to fix the DLC item 5 Star Dog Potion.  And not one person seems to know how to fix this potion glitch/bug whatever.  Ive redownloaded it about 10 times now, reset the console, powered down the console changed my dog breed back to collie, deleted all fable 3 related articles from my xbox and downloaded again.  All that being said my dog potion i spent my money on is still not working, every time i interact with my dog it does not give any options to use the D-pad at all.  So again, can anybody tell me how to actually fix this issue?

 

Discussion Info


Last updated July 3, 2018 Views 6 Applies to:

I had the same problem. When I started a new file it was there. But it wasn't there for my older existing files.

go out of game - system settings then under fable 3 - check to make sure file fully downloaded - if not re-download it - also with almost all dlc's in this game it is advisable to be out of game, while they are installing. if you are playing while installing they almost always abort

Didn't work. Mine's missing too. Guess I'll just start over...

I as well have the same issue and have tried just about everything.