DLC not working on new console (Same Hard Drive)

So this is the 3rd xbox i bought and the problems are just getting more and more annoying. first time my xbox refused to show anything thats running on the tv, no this was not a problem with the cables i tried 3 different cables, an HDMI and 2 different AV Cords. Not only could xbox support not help me fix this problem but they ended the phone call with the sentence "You're warranty has expired" so i bought a new xbox. not too long after a similiar problem occurs and my xbox refuses to read game discs. once again xbox support couldnt fix the problem and my warranty expired. so i bought another new xbox. now whats the problem? all the downloaded content on my hard drive from my old xbox doesnt work on my new xbox even though its the same hard drive. i called xbox support 3 times and they finally told me about a thing called license transfer. but the guy on the other end of the phone hangs up after failing to help fix it. following his directions all that happend was a message popped up saying "You have found a glitch in the system" and when i went back it says that i cant license transfer for another 4 months. (500$ the first time i bought my xbox $300 the second $150 the third $820 on games [+hundreds more for games that have been sold for less than a quarter of the price they were bought for] $300 for the 5 remotes (2 of em have broke) 300 more on xbox live (4yrs +1yr for other account) about $100 on microsoft points $60 headset $60 hdmi 50$ batteries dont know how much for the play+charge kit) and this is for what a **** @@@ console that wont even work and just milks money out of people this *** should be illegal what the f*** i didnt even include the tax imagine 12% more to all of that f****** HST. I shouldve bought a PS3. the games and stuff might be worse but atleast i dont have to waste so much money :@

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

Since it says you can't do another license transfer for 4 months, it sounds like it may have done the first part. Have you tried redownloading the content?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.