Disc Unreadable

I keep getting a disc unreadable message for Halo Reach and Lost Planet 2. With Reach it's only during Multiplayer, usually directly after a match. With Lost Planet 2 it's kinda random but happens more frequently when I attempt to play a multiplayer game.

I've been able to play all of my othetr games with no problem. I've even tried playing after installing Reach to my HD (Lost Planet 2 was bought through games on demand so is on my HD already)

I'm using a 360 with a 20 gig HD

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Disc wont read sticky.
Hopefully something in here will help you Grif.

Have you tried deleting and re-downloading LP2 from your download history?, worth a shot maybe.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.