COD GHOSTS STRICT NAT, NAT OPEN XBOX ONE.

I've tried everything, but nothing works out I already opening doors and nothing. please help me.In one xbox nat is open and cod ghosts strict

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

You should first turn on UPNP, turn off DMZ if you are currently using it and then put your Xbox One's IP Address into your DHCP Reservation list. This is all under the router website and then port forward: 3074, 3075, 3076 UDP and TCP ( go on till 3080 if you want, that will be better) and then thats it. Save settings and if it doesnt work then power cycle your router/modem and xbox one (unplug it and wait 30 seconds). Hope that helps you, bro.

Mine keeps saying Moderate no matter what I have tried, however I will look into these settings tonight and see what I have as well.  Thanks for the information.

For some reason my xbox is not playing my Call of Duty Ghosts at all. Anybody know why that would happen?