COD Elite Doesn't Work 'Incomplete Download'

I downloaded the Elite app when it first came out, but couldn't get it to work, then got an email saying that my COD Black Ops picture was unsuitable and therefore I couldn't use the Elite app until I'd changed it.

Since then I've updated my picture and tried to install the Elite app 3 times, but it's finished it just keeps saying 'incomplete downlaod'. I've tried it 3 times no with the same result.

I seem toremember the email saing something about an email to contact if I had any problems, but now I can't find the email and I'm not sure what else I can do.

 

Any suggestions would be greatly received.

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Try deleting the Elite app completely from your harddrive and re-downloading it. Also try doing so from your download history. If that does not do the trick you should delete the cache and try again.

Cheers, deleting the cache and re-downloading worked!! I'd forgotted and about deleting the cache, so long since I last did it.