Co-op issues

Anyone else having issues playing co-op?  Connecting to friends to play simply will not work.

 

Discussion Info


Last updated July 3, 2018 Views 4 Applies to:

It's working OK for me, though last night my friend's game freaked out and dumped him to the Home screen while we were setting up the game. Restarting the Xbox fixed it.

 

One thing we noticed was that the Xbox One labeled both of our routers as "strict" (Settings -> Network). We both have Xbox 360s as well, and those always showed "open". Well, the issue is that the Xbox One and the Xbox 360 both use the same ports (The Xbox One uses a couple of extra ones that the 360 didn't) so if your router is set up to forward the ports to the Xbox 360's IP address, then those ports are effectively closed for the Xbox One. Hence you get a "strict" NAT, which can cause issues with matchmaking and chat.

 

The Xbox One also doesn't use UPnP correctly (which would automatically configure the ports for you), so unfortunately the fix is that you have to go into your router's configuration and manually forward the ports to the Xbox One IP address. This also requires that you give the Xbox One a fixed IP address instead of using DHCP.

 

There are more details about testing/fixing NAT issues here.

haven't tried co-op but a friend is planning to get it so we'll try soon