Citadel DLC not working

Hey Guys,

I'm having an issue with starting up the DLC, when I go to enter the Galaxy Map, it says I have Part 2, but no Part 1, when I have both installed on my Hard drive.

Not sure what this could be, anyone else having this trouble?

The only thing I could possibly think of is that the DLC is actually tied to my brothers account on my console. But the license is on my console, so I should be able to play it, like I have all the other DLC.

 

Discussion Info


Last updated July 3, 2018 Views 187 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

No your not the only one >:-/  Did you check your storage to make sure they both downloaded correctly, like no yellow warning sign?

I am having the same problem only when I download part 1, and yes I have deleted it and downloaded it again, it downloads in seconds, literally, and when I go to play it it says I have part 2, but need part 1. When I go to storage to check if it downloaded there is a yellow warning sign next to it. I am getting increasingly frustrated to the point where it crossed my mind to through the damn thing off the balcony and switch to the Playstation.

Yellow warning signs usually means that it is incomplete. However if you say it downloads in seconds then its already been downloaded and no you have not deleted it or it wouldnt download that fast. I would delete part 1 and 2 for sure, clear my catche, and download then again, then after it was complete load the game and get your updates that you deleted by clearing catche. There is another thread of this on these forums. I dont know if they ever found a problem or not but its worth looking up.

Alright I found the problem, I downloaded part 1 and got part 2 then I downloaded part 2 and got part 1 and it's working fine.

Odd but hopefully others will see this if they have the same problem.

Don't see how this could fix the problem, I've downloaded both Part 1 and Part 2.

Unless you're meant to download Part 1 first?

I'm having the same problem. I've tried downloading it both ways. I don't see how the galaxy map can tell you you've got part 2 though. You wouldn't have fixed it by ow and be able to magically tell me how, would you?

I just wanted to verify that we're all having the same problem here (except WaPuS who had a different problem on the marketplace end of the download)

My problem is: I've downloaded both DLC's, part 1 and 2. And then gone in game and have not received a prompt to start them (You should get an e-mail at your private terminal) I just want to verify that EVERYBODY here has not received any e-mail to start the DLC, correct?

(Just making sure we're all in the same boat)

To clear one thing up the mission is not available until the assault on the Citadel. You know the one where Cerberus attacks the citadel/ Once you have completed that it will be added to your orbit of the citadel menu. You will also receive a message from Hacket. If this isnt the problem then check this out, its not rocket science. Download part 1 then download part 2. Done. You have it and can play it after the coo attempt on the citadel.

Yes, I have at least (I can only speak to myself) gotten up to, and past Cerberus' assault on the Citadel. I am all the way onto attacking Cerberus' main base in the Sanctuary nebula or w/e.

The problem is, the game doesn't see that I have the DLC. A good way to identify if it's a gameplay issue or if it's an actual bug is to go to the stores on the Presidium Commons. If the Sniper High Velocity Barrel is for sale, then the game is correctly identifying the DLC.

However in my case: No message from Hackett, no DLC features evident. Fully downloaded and in place on my hard drive. I've re-downloaded it without deleting the original, and when that didn't work, I completely re-downloaded it and cleared my system cache. Still no dice.

Then look up EA help center in your browser. Call them, message them whatever. Their phone number is 1-866-543-5435.

Call them. You may need to wait on hold for 10 minutes or so if you call them but they will answer.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.