Can't see blue flame or nameplate

Anyone else have this problem.  I did what was asked on their site and it even gave me a congrats you got the blue flame helmet.  I started reach and it was there so I equipped it.

 

I just can not see it in game.  I looked when I died but there was nothing.  Does it go out when you are killed?  Is there a specific helmet it works on?  Any knowledge shared would be helpful.  Thanks

 

Discussion Info


Last updated July 3, 2018 Views 5 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Bob's going to have fun with this thread... :P

.

Yes it goes out when you die.

.

Although, most important, ARE YOU SURE YOU HAVE IT ON?

Yep, it is definitely equipped...I don't see it when I see my armor in the armory nor when I am in game.  Also not star nameplate.  :(

The star you should get if you've played a BTB-Allstars match today.

Thanks...but now all of a sudden my blue flame armor effect has gone away from my armory...this is nuts

FYI...incase you played one game and hopped on B.net- the BTB-A* version won't unlock until next friday. If your Blue flames disappeared, just go sign up at bungie.net and verify your email.

Ahhh  thanks

Actually, Speedy, Bob was too busy playing one of the four games he got for $118 total today .

.

Seriously though, I don't know the exact conversion to USD, but I was pretty happy with that purchase . Turns out Dragon Age is a pretty damn good game too .

I just happened to notice something similar, myself.  See, i already did the website stuff for blue flames and nameplate last night, both of which aren't showing up today.  In addition to that, while Bungie.net shows my progress of the weekly challenge, the game shows 0.  Everything was there in-game last night.  No, something is definitely wrong here, cause how would you go about reverifying the blue flames?  Plus, Bungie.net still says my nameplate is in use but it didn't show in-game.

I have the challenge problem too, it seems to reset itself in-game if I turn off my 360 , but bungie.net shows my actual challenge progress. Haven't tried the weekly at all this week, but the daily ones that require to kill a certain amount etc. I noticed are reseting. My blue flames work however, well they did yesterday, dunno if they magically disappeared or anything today though.

Yea, just checked and my blue flames are gone too. :/

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.