Cant purchase

Dear Support Team.

 

I can't seem to purchase any addons for the Age of Empires Online game. I've read, that there are problems in Hungary, becouse you can't purchase anything ingame,and you recommend buying through the Live marketplace becouse that works. Well that doesnt work either. Tried buying ingame, throught the marketplace, and through a web browser. I even tried another browser, and updated my system, but to no avail. Still cant buy any AoE online stuff.

I know my card is ok. I bought tons of stuff with it, so i am not inexperienced. There is money on it too. Wrote and checked everything, maybe i miswrote something but no.

Is this a known problem? Will it be fixed soon? When can i finally play.... the free is not giving me enough fun, and already i am geting tired, trying to finally buy this game...

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

Oh and i am playing from a PC, and an error code i recive when trying to buy ingame is:800700e8 if i remember correctly.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.