Cant Download Anything Using Active Downloads Screen

I don't seem to be able to download anything that uses the Active Downloads screen. My connection and setup seems fine I've even setup up the port forwarding as suggested.

Speedtest.net reports my speed around 17Mbps download 0.8Mbps upload which I would think was fast enough.

I can browse the Games marketplace freely with little or no delay but when I try to download anything it opens the Active Downloads screen waits for a few seconds then says Can't Download [whatever I tried to download]. No error code.

Whatever I am trying to download is added to my download history.

Got about 100G free HDD space

Clearing the system cache caused me to be signed out of Xbox LIVE the next time I tried to download anything (the gears of war 3 trailer I think, I'm trying different things all the time). Restart got me back to the usual problem.

I can watch trailers from the Zune thingy with almost no delay. The video just pops up and plays smoothly no problem there. Pretty good picture quality too.

If it helps I am in Brisbane, Australia with Telstra Internet.

I was considering signing up for a paid account bit if I can't download anything there is no point really.

Any suggestions on what I could try would be helpful.

 

Question Info


Last updated July 4, 2018 Views 4 Applies to: