Cannot play Black Ops and Assassins Creed Brotherhood

My Xbox drive broke last Christmas so I sent it in to get repaired and I got it sent back. I was playing all my games fine and then I got Black Ops and Assassins Creed. The xbox recogninses the games as it shows up the image. I press A to load the game up the screen goes black and then goas back to the dashboard and give me a disk read error. Every other game I have works perfectly and the disks which do not work, do work on other xbox i have tried.

 

Help!

 

Question Info


Last updated July 4, 2018 Views 3 Applies to:

Have you tried working through this guide? And to be clear, was your console sent back from a repair center having been serviced? If the repair was completed, was it paid for, or covered under warranty? If it was paid for, your new warranty should still be active.

If that guide doesn't resolve the issue, you'll want to set up a repair here.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.