Can't Download Game Again

I purchased Fallout: New Vegas during the Bethesda sale back in June and downloaded it with no problem. Due to my current lack of hard drive space, i had to delete it before getting to play it, in order to make room for other games. I made sure to make a note to re-download it when I got the chance. I tried downloading it again this afternoon, but it stays at 0% for about 5 minutes before saying "Cannot download Fallout: New Vegas". I have cleared my cache, deleted incomplete files and I'm using a wired connection, but nothing seems to work. I don't appreciate spending $7.50 for a game that I cannot even play after purchasing. Please help me clear this situation up, as I am really excited to finally try the game. Thank you for your time.

 

Question Info


Last updated July 4, 2018 Views 29 Applies to:
Answer

Hey everyone!

Very sorry to hear about the issue with downloading games. We have forwarded this issue up to the proper team to investigate, and we'll be posting any updates we receive in this thread here!

NOTE: I will be merging recent threads with similar issues into this thread here so we can keep everyone up to date in one spot.

If you haven't already, please try the following troubleshooting steps in attempt to solve this issue:

Keep in mind while this post is marked as "answered", it most certainly doesn't mean the issue is solved. This post will be marked verified for better visibility for new users coming into this thread. :)

Thanks for reporting this issue, everyone!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.