Can't connect to Gears 3 MP

Any help is appreciated.  Out of the blue I'm having trouble connecting to a Gears 3 MP match.  First, the first 6 weeks after release I had absolutely 0 problems, then I pop the game in and I can't connect to my friends, or a MP match.  I do finally get in (after about 7 min.) and it is all bots.  When I get in a pre game lobby I get kicked when the game loads.  My modems settings haven't been touched and this IS the ONLY game that I have issues with.  And before anyone asks: NAT has always been open, I'm at about 12MB/s Down and a little over 1MB/s Up.  Again, my modem is set up just fine for all other games and for this one when it first released.  I've read a few articles that others are having the same problems.  Any suggestions?

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

This is a stretch but.. you could try to clear your XBOX 360's System Cache, delete your DLC content manually (My XBOX > System Settings > Memory > Hard Drive > Games > Gears of War 3) . After you've deleted the DLC content try to go into the game and just download the free booster pack that it asks you to download and see if you can enter a game that's not just bots. Let me know if that works out for you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.