BUG!!! - Forza Motorsport 3 - two cars stuck on car level 4 XP 64000 - BUG!!!!!

Sorry to duplicate, but I have Gold membership on this and thought I won't get any help on other account.

So for two cars I happend to get exact 64000 XP on car level 4, which is supposed to elevate to level 5.

It says level 5 on the cars - but screen after games are stuck on car level 4 and 64000 XP, 0 XP left - and never updates from there.

Two cars blocked from making further progress.

I have Ultimate Collection Forza 3, as well as Forza 3 bundled with console, both installed on HDD.

Thanks.

 

Question Info


Last updated July 4, 2018 Views 25 Applies to:

I think the guys and gals on the Forza Support forums may be able to help you with this.

It sounds like a glitch with the game itself - out of the control of Xbox

-

Support can be found here: forzamotorsport.net/.../support.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think the guys and gals on the Forza Support forums may be able to help you with this.

It sounds like a glitch with the game itself - out of the control of Xbox

-

Support can be found here: forzamotorsport.net/.../support.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you.

As it turns out - reading the manual - car levels are not more than 5!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

Why don't they simply put a text on screen saying "Level 5 Max car level reached" or something like that.

No need to force everybody to manuals to know what is happening

Screen just says  "Level 4 64000 XP , 0XP left".

On Forzamotorsport.net I was not able to login, some strange server errors or something as soon as I click sign in.

So exactly how you are to contact Forza support I don't know.

Error

Forza Motorsport Home

We're sorry

An error has occurred. Please try again later. We're sorry for any inconvenience.

This is now, and was like that yesteday too.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Greetings, BookishFlunky90. Did you try to sign in to their forums? When was the last time you attempted to sign in? If it was a while ago I would recommend trying again. Give it a shot and let us know if you're able to access their forums. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you.

It's the same now - fourth day in a row.

On forum front page "Welcome to Forzmotorsport.net forum" and the Sign In button.

Clicking it give the same as mentioned above in my previous post.

If going to Forzamotorsport.net main page and click sign in at the top.

It becomes a blank page and url is saying something 248 MSPPError in the url.

I tried changed region to UK or US, but it's the same.

My guess is it has something to do with cookies or the "sv-se" thingy had been at the swedish forum before. I don't know. But it seems something does not have a fallback from unknown to one that exist. Just guessing.

I have been logged in to Live under a different id before, I have some posts with that from before I bought the xbox.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Can you try another browser and let us know if the issue persists? Thanks, please keep us posted!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thank you.

Already did that - Firefox 3.6 and MSIE 7 and result is the same.

Also tried deleting cookies in MSIE but no difference in result anyway.

OS is XP SP3.

Cannot upgrade MSIE cause VS 2005 does not work properly then.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks for following up. IE is two versions out from 7. If you can't upgrade, I would recommend trying to log on from a different computer that can. Give it a shot if possible and let us know how it works out!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I took a laptop with W7 and that seems to support what is needed.

So getting to login, I was able to verify email with this W7 machine.

Then, funny enough, it worked just fine in XP computer too. I could just press SignIn and I didn't even have to enter something, I was just logged in. This with old Firefox that I use, as well as MSIE 7.

Why MSIE 8 would be needed, I don't know.  I could register and do everything for xbox and forums and stuff on XP, but not Forza site - whatever that was about. You got all these "Live" thingys - xbox live, windows live and I don't know what. Some kind of live ID I have registered many times over the years to get support on my Visual Studio various versions since the 90's. I can just say it's very confusing.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.