Brand New Game Add-on Code is invalid.

 I bought the Killer is dead box set that comes with Game Add-On Code but it wont work. It says its invalid but I know I've entered it right. What can I do to get the add-on I've already payed for?

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

i am having the same problem with my gta 5 money that I got a at Walmart I went to zreward.com entered it got the code but when I enter it it says that its invalid

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am currently trying to resolve the same issue with two DLC packs that came with my LEGO Lord of The Rings for 360.  It was purchased from a Walmart in Canada.  Already dealt with tech support via chat and phone, and so far has been a huge waste of my time.  It's very frustrating when you buy something and now you're told there's nothing that can be done other than keep trying on contact the manufacturer!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

When posting a problem its best to make your own thread as the troubleshooting isn't the same andnjot all settings are the same

With prepaid codes the region of the account must match the region. Of the code so if you have a us or non cannafa account it won't work

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My region is set to Canada (English) and the game was purchased in Canada.  The back of the game does say "Made in USA".  I tried today to switch the region to United States for my account, but I still get the same error when entering the code on here.  I'm not sure who else to speak with regarding this issue.  I've now been trying daily for the past week with no success.  Any other suggestions ngocphi?  Thanks for your quick response too!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem with the Overkill Edition game add-on for my brand new and sealed Army of Two: The Devil's Cartel game. I bought it new and it was still sealed in the clear wrapper with the Microsoft Security Seal still intact. I opened it. Put the disc in my console. It loaded. Updated. Then prompted me to install the HD content (not the same thing as the Overkill add-on).. The game then loaded up fine so I exited out and went to my Settings/Redeem Code. Input the code from the add-on slip included with the game. Verified the code was correct. Clicked submit and after a few seconds the message came up "Code Entered is Invalid".

How does a brand new game add-on code come back as Invalid??? The game was brand new and the package was sealed! And the MS Security Sticker was Undamaged! What do I do to get my add-on content? It is already paid for!!!

Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Trojan;

This thread is over a year old. It is preferred that you create a new thread detailing your issue rather than posting in an old one. With that said, first I would check to make sure that you've typed the code correctly (some characters will look like others, like a B may be confused with an 8) and you should also make sure that the code hasn't expired. If these suggestions don't help then please create your own thread so all of the responses will be directed towards you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.