BO 2 Multiplayer problem

I can't play a multiplayer game on BO 2 ever since I played it on my friend's older Xbox.  I can play zombies on multiplayer but nothing else.  Sometimes I get a message that says "storage device has been removed".  I updated at my friend's house and I'm wondering if there is a problem with the update.

 

Discussion Info


Last updated July 3, 2018 Views 1 Applies to:

Hmm. First I've heard of something like this. Check Activision Support (support.activision.com/Contact_Us) - you can e-mail, call or use the various social networks they're in to get support.

I too am having multiplayer problems since the latest patch was released. When looking for a public match it will not join me to any and constantly sits on searching. (I've tried changing search preferences, my NAT is OPEN) The only way I can play a multiplayer game of Black Ops 2 is if I am in a party with another player who has invited me, or if I go through my recent players list and join in through that.

-

I did a check with other games and can join multiplayer no problem, even on MW3 no issue. Just for some reason after the recent patch I can't search for any matches publicly.

[quote user="EighteenFlea250"]

I can't play a multiplayer game on BO 2 ever since I played it on my friend's older Xbox.  I can play zombies on multiplayer but nothing else.  Sometimes I get a message that says "storage device has been removed".  I updated at my friend's house and I'm wondering if there is a problem with the update.

[/quote]

Have you tried clearing your cache?  That should fix it if it's the update that's causing you problems.

This is going to sound stupid, but what is my cache?

It's one of your system settings - storage device. On the HDD there is an option to clear the cache

@ EighteenFlea250,

Did you connect to the internet when you were at your friends house?

Your 360 might have his IP settings stored on it.

Go to System>Settings>Network>Configure Network>Restore to Factory Defaults (network settings will be restored ONLY)

Reboot the 360, Find your network from the Available Networks list and enter any passwords you have set.

I cleared my cache and it didn't help.  

When I was at my friend's house I was connected to the internet because I downloaded an update.  I did what Bird125 says I should do (above) and restored the factory defaults and now when I am at the main menu and I try to choose multiplayer, the screen goes back and freezes.  The only thing I can do is shut it off.

i am getting the same problem. First i was getting a green screen in between matches and i would get booted to the main menu. Now i cant even play without it freezing. I have been contacting Xbox support but they have told me to do all of the above things mentioned and nothing has worked. I swear i have cleard my cache 100 time now and its still freezing.

I followed the instructions for troubleshooting a frozen screen on the Xbox live support page.  I even took out the hard drive.  It finally told me my console needs servicing.