BF: Hardline stuck at 20%; won't finish downloading. Livechat tech support unable to help.

I am trying to download Battlefield Hardline. I bought it on the Marketplace a couple days ago, and no matter what I do, once the download gets to 20%, it goes to the queue, and I can’t get it to download any more.  It always gets to 20%.

I’ve tried deleting the installation and restarting it numerous times. I’ve done hard resets. I’ve searched thoroughly to find solutions for this problem and the only thing I’ve seen was restarting downloads, and hard resetting. I’ve read the forums here, and on the EA support site.  I've had live chats with tech support from here, and with 3 people at EA.  Nobody has been able to help me at all.

Things I have tried: 

  • Canceling the install, restarting it. (I think im up to 9 times on this)
  • Uninstalling/Reinstalling the Battlepack DLC that came with it
  • Hard Resetting, even through settings-power&startup
  • Installing on wireless and wired connections
  • Clearing MAC address
  • Clearing Persistent Storage in the Blu Ray settings
  • Resetting my router.
  • Unplugging power chord from the console and the power brick
  • Delete Profile from xbox, re add profile
  • Delete all saved game data from cloud and console

What else can I try? I want to be able to play this game, but I am so frustrated with this right now.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hi Valint,

I'm having the same problem as you. I've responded to the threads above (including the one I made) about what I've found.

You appear to share the common characteristic that our downloads get cut off at approximately 9 gigabytes of data. There appears to be a range of at least one gigabyte here, which may just be due to approximate measurement with the percentages.

Who is your provider? Are you on a college campus? That's the easiest solution I've found. If you check your bandwidth usage, you go from your normal download speeds to hilariously slow, perhaps one kbps, once the download essentially fails. My theory is that we're on similar (or the same) college campuses, where an administrator has capped the size of a single download at a fairly high but, in this case, prohibitive number; approximately 9-10 gigs. You'll notice that you can download a six gigabyte file with absolutely no problems.

I really don't know who's end this is on, and it's driving me crazy. If you see this and can give me any more information about your situation, I would appreciate it. The next time I hit up MS support I'd like to have more concrete information to give them.

EDIT: I should mention: the one thing I'm positive about is that the fault does not lie with the developers, so contacting EA won't accomplish anything. The games I'm having trouble with are by two different developers. It seems that this must either be an issue with the MS store or our ISPs.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.