Battlefield 4: Second **** issue

When I play any of the "Second ****" maps, about mid-way through a match character models will stop appearing. Not every single one but a good percentage, I'd say maybe like 35%. That leaves me at a huge disadvantage obviously. By the way, this also includes teammates. Anyway, when I do get killed by one of these invisible players, all I see is a floating gun on the death screen. Even later in a match, I'll start spawning without my primary weapon. I can select it, but it's invisible or shows a blurry version of my pistol and has 0 ammo. If I survive long enough, it'll eventually appear, after like 3 minutes or so. I can however use my pistol and med-kit in the mean time, but that's about it. What I really want to know is if anyone else is having this issue. I've found nothing about this anywhere, and I would be shocked if it were only happening to me.

Additional info; When I installed either of the BF4 expansions, after the download, the install stopped with a "Sorry we won't be able to install this looks like it wasn't formatted quite right. Check the Xbox Store to see if another version is available. (0x87de2717)" 

I went around that error by just hitting try again a few times. 

http://i.imgur.com/jcZlal8.jpg

 

Question Info


Last updated July 4, 2018 Views 5 Applies to:

As far as my understanding goes, Battlefield 4 is having a few teething problems and DICE & E.A are working towards fixes for these issues. My advice is to pop on over to the Battlefield 4 forums and see if anyone else is having the same issue as you are. If you can't find anything don't be afraid to start a new topic in their BF4 support forums. You can find the forums HERE

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have been having this same "invisible player" issue for the past 48 hours or so, including moments where my own character model would disappear and have problems with its weaponry per ID Tre's description.  Also, at times, other character models would do things like, run without weapons, sideways, or backwards.  Also, towards the end of the game, there would be no end-of-round music to signal the game is coming to a close, and there would be no end of round score board.  After the round is over, the game would typically freeze between maps.

Am also unable to "turn party chat on" after joining a party during this same period of time.  I'm thinking that it may be Xbox One-created lag, as my other friends in these games haven't experienced the same issues.  Have done things like cleared my cache at restart.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

the zero health is a known EA issue.  Hopefully DICE will fix it in the next patch.  Second Assault runs fine for me- I have been playing it since it came out for the premium members.  I only play CTF though on SA.

I recommend you reboot your X1 like this:  With the console on, press and hold the power button on the console for 5-8 seconds until it shuts off.  Unplug the power supply, wait about 30 seconds and then plug it in and reboot.  You should see the green splash screen upon reboot.  It may take a minute to boot all the way to the home screen.  If you did not see the green Xbox splash screen, please redo it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.