Anyone else having multiplayer issues

So yesterday I was playing with a friend of mine in a party for the first time and I would select conquest for the game mode and it would always throw us into TDM. I thought it was because of the party or something but even after I left to party to try it on my own it always threw me into tdm. I tried to see if I could get into any other game modes but it always threw me into tdm.

--

Today, I tried to do conquest again, it got me to the loading screen but then it would say connection lost and throw me back to the game mode selection screen. I skipped over tdm and went to Obliteration and that worked. Then I tried rush and a couple other game modes and all of them did the same thing as conquest.

Has anybody else been experiencing this?

 

Discussion Info


Last updated July 3, 2018 Views 1 Applies to:

Yup, its not just you.

Happened to me yesterday, searched for Conquest, got thrown into TDM. I also got quite a few ... "Connection Lost to Servers" ...

Struggling to get into games today, I guess the servers are taking a bit of a battering. Bit of mindless COD violence is in order instead then and I'll try this again later.

I'm having a hard time connecting too.  It Freezes on a black screen then says "The connection with EA Online was lost".

Alright cool, guess I'll just wait it our then, or head over to ea and see if I can figure out what's going on to pass the time.