Anyone else getting "can't connect" errors constantly lately?

I've searched the internet for "EA servers down" and get nothing but news of them shutting down servers for old games.  It's not just BFBC2 that I get the error with... NHL'11 as well.  But while I get the error nearly everytime I try to play the last few days, I can see at the exact same time that friends on my friendlist are still able to play. What's up?

 

Discussion Info


Last updated July 3, 2018 Views 3 Applies to:

I'm getting the message "FAILED TO CONNECT TO EA ONLINE". I was playing it just this morning and now I can't. My friend is playing it just fine but I can't join in or start a game of my own. Any word on what's going on? My internet connection and equipment is fine so I know it's not on my end.

-John-

Might be a small hiccup on their end or to a certain server you're connecting to. I don't keep up to date with their server uses, but if you're connected to the UK, that might be the problem if you're based in the US. Maybe try switching regions and see if you can connect.

I have had this problem for days. Had back and forth conversation with EA reps who haven't helped at all.

SO you know what I tried? A different gamertag and you know what? It worked first time trying to sign in.... try that and write back if it worked.

Currently having this problem, anyone else?  How do you change the region?  This is really ticking me off!

OP- Seems we have the same gaming habits.  BFBC2 didn't work so went to NHL 11... same problem...

Thank god I am not the only one with this problem. I have been playing BF Bad Company 2 online for over a year now without a problem. But since a week or 2 I am unable to connect to EA online most of the time. And to be honest, I have this with ANY other EA game I have tried lately. FIFA 11, NHL,... All worked fine until just a week or 2 ago. All same problem: can't connect to EA servers/EA Online... And so far, I have got no information if the servers are down or not.

I can play any other game that is not made or published by EA just fine. So the problem is not to be found here but at EA.