Anyone else? Civil War Bugged

So, I sided with the Imperial Legion and have made my way all the way to the point of Retaking Eastmarch.  The quest/fort just prior to actually taking Windhelm.  I go to the Imperial Camp to talk to Legatte (sp?) to do the "Reporting for Duty." but nothing happens.... I don't have that option.  I've reloaded old saves and worked my way back up to the quest, and it still won't work.  I've read online that it's a bug, but apparently people have actually/somehow gotten it to work.  Wondering if anyone else encountered this, and what they used to advance it? (If they did, in fact, advance it.)

 

Discussion Info


Last updated July 4, 2018 Views 3 Applies to:

Well the problem is really that you have joined the Imperials.  The Xbox acknowledges that the Stormcloak rebels are actually the proper choice to make and has made the right decision in not letting the empire win.  Apparently the Xbox was never factored in by the Thalmore to overthrow all their plans.

-

Seriously That's weak-sauce man.  I hope you get it working again.  If you read more on it and find there was a bug in a choice you made.  Concider keeping that game save on another device or something untill they roll out a bug fix.  I have been fortunate enough to not encounter any major quest breaker glitches.  

The only o e I encountered was when I first joined tried joining the storm cloaks with the initiation mission active. After playing around for a few hours I decided to finish it and become a stormcloak. When I went to go turn it in he wouldn't let me and had me go into an infinite loop with ulfric and the other guy. His name escapes me right now.

Ok, this was weird.  So, like I said... she wouldn't give me the option "Reporting for duty."  I tried about 10 times and nothing... I even attacked her and it didn't help.  So, I figured i'd give it another try tonight, except instead of fast traveling directly to the Imperial Camp, I go to a Dwemer location that's really close to it.. walk over to the camp and talk to Legatte... sure enough, there's the "Reporting for duty" option!  haha.  Needless to say, I wound up finishing the Civil War quests tonight.  Just got a few more Daedric Quests to complete and i'll have my 1000.