after performing an update it now say disc unrecognisable

there i am playing black op's, everything is working fine, the normal single player, the on-line multiplayer, then i turn it off for the day. the next day it tells me that i have to update the game or be signed out of xbox live, so i do, then after the update it says it cant recognise the disc. what's going on here? am i suppossed to go buy a new disc, at least when the NES couldnt read the game all you had to do was blow on the cartiridge. Ive just bought medal of honour (abit late i know)-guess what, have to update game, now it doesnt recognise disc?! but if you delete all game info from system settings and cache info then disconnect from internet-hey presto! the game works fine. but i guess i'm not allowed to play online! what gives????????

 

Question Info


Last updated July 4, 2018 Views 1 Applies to:

Hey there! Have you tried using these discs in another console, or tried using different discs in your console?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.