after downloading citadel (1 of 2) it ends up as (2 of 2), and i can`t download (1 of 2).

so i tried to download  the new citadel dlc for ME3, and when i check my active downloads it wasnt there so i tried again & it was then downloading as it should. after it was finished i couldnt find the second part on the marketplace so i put me3 in and thought it would give me a link of sorts to part 2 of 2, to my surprise when i opened the map in me3 it said i only had part (2of2). i then checked the hard drive in storage and it said that i indeed had citadel (2of2) and not part 1, so looked and i tried to download part 1 again and it just jumped from 1% to 100% and i checked the hard drive again and it still just said (2 of 2) so i tried to play again and it still said i needed part 1. i then deleted all the citadel dlc from my memory (which was just citadel (2of2) and started over entirely, and after it finished downloading it again said that i only had citadel (2 of 2)....... somebody save me from this unholy crysis.

 

Discussion Info


Last updated July 3, 2018 Views 2 Applies to:

I'm having the same exact problem. I can't find nobody to help me with it either.

Hit the guide button, go into your account, then open up your download history. From there you can see what you have downloaded and you can continue a download from there. Example: If you download dlc from ME3 menu then when you leave the game the download drops. You must continue it through your dlc history. Also part 1 is 1200 points while 2 is free. Hope this helps.

i would suggest clearing the cache

deleting corrupted files,

then removing and re-adding the memory device

I would suggest giving up entirely as I have downloaded it 'twice' and the same thing is happening. Part 2 jumps from 1% - 99% to 100% complete in a matter of seconds yet it is nowhere to be found on my hard-drive. I think ill play something else lol

If it jumps like that then you have already downloaded it. Dont look on your hard drive look at your download history. You must have 1 and 2 for it to play and may be listed as one on your hard drive when both are complete. Sounds like you downloaded 2 enough times now try 1. This isnt rocket science. If it still doesnt work then go to the main menu of ME3 and download BOTH from there. You will have to wait a while on the ME3 main menu. It is 4 gigs. If that doesnt work then call the EA help desk and they will take you through it step by step. If it still doesnt work then yes go play something else.