Achievement Glitched HELP!?

Hey guys,

I'm a big halo fan, and completed most of the achievements in all halo's.

Now in halo annivesary, i got the achievement to find ALL terminals, but not

the achievement to find HALF of them :| So it kinda glitched for me, but it is the last one

i need foor full completion, so it really bothers me. Anyone who can help me out??

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Your best bet would probably be to restart your game. I'm not even sure how that kind of glitch could occur, but looking at your achievements, it sure did.

Well, thanks for looking in to it. But i've already tried that. I hope more reactions come in to this so someone can eventualy reset the achievement or unlock it for me. As it would probably be the only way to fix it :c

I don't have anything to offer, but bump for MS to see

Have you tried just finding them again? maybe the double-tap will make it pop.

If you haven't found a solution yet you might have to delete your game saves and try to find them again