AC2 possible game-killing glitch (possible spoilers)

No AC2 forum yet so forgive me for posting this in this forum. In AC2 I started sequence 14, where you go to Rome, kill the pope, etc. However, I seem to have run into a glitch that has effectively killed my game and was wondering if anyone else has heard of this.

I start off sequence 14 on the little dock area and begin my ascent up a building. On the landing this path leads to, there should be some guards that need dispatching and a lever with needs to be activated. This lever then opens the door next to it, allowing you to continue on. However, when I get to the landing, there are no guards whatsoever and the lever I need to flip to get through the door cannot be interacted with. No music is playing, either. In other words, I can't continue on because there's no way past the first door.

I got all of the codex pages, did the thing where I looked at the via eagle vision and arranged them to create the map of the earth. I then put the apple of eden into the pedestal thing, which shot the assassin's creed logo on the map. I then talked to Mario and arranged the trip to Rome. I also completed the first DLC (sequence 12) and about half of the seconds DLC (sequence 13). Collection-wise, the only things I was missing were 60-ish feathers and two weapons. So, I don't think I was really missing anything, unless it doesn't like the fact that I didn't finish the second DLC and, if that's the case, it should either give a warning or not let you continue on to Rome.

Anyone else heard of this problem?

 

 

 

Discussion Info


Last updated July 3, 2018 Views 4 Applies to:

Nope, didn't get that far into AC2 before I got my own game-killing glitch. As soon as I got to Forli it gave me the error that my storage device was removed, and the next time I went into the game my save file was gone. Tried to restart from scratch, got the same error around memory sequence 3 and that was all she wrote, I traded the game in and watched the rest of the game I missed on YouTube.

Hoping I don't get the same issue in AC:B