A Warning to those who buy the Regular RE5 and Platinum Hits

RE5 has something wrong with it where some copies will not work. Essentially it wont load the buy screen after the first two cut-scenes in chapter 1-1 making it where you cant get far enough to be able to upgrade your weapons. And it seems to fail at 48% and i have plenty of proof.

There is TWO (Separate) problems, one has a fix. the other might*

1. You have the gold Edition, and Mercenaries Fails

FIX: Delete the Figure DLC (the free one that shows you the pay for costumes like sheva's business outfit)

2.you fail at 48% on install, and you immediately crash to dashboard with disc read error right after the first two cut-scenes in the game.

SOL: ya well some people have "fixed" this by really wierd ways.

1. Delete RE5 Demo? it worked for one

2. remove HDD put back several times and keep trying to install to HDD each time

3. remove HDD use fresh 8GB Flash drive and itll probably update your 360 too and install it to that. 

4. Clear Cache and keep retrying.

5. Buy Games on Demand Version (STILL dont download the figurine DLC, ive read reports it STILL gives you "disc" read errors...(lol no disc..its downloaded)

I have read this happening to:

LE Red 360's

Slims

Elites

Phat 360

so basically ive come across someone saying this exact scenerio (1-1 failing, 2-3 failing, and fails around 30%-48%) in every one of these xbox's

Documentation

http://www.gamefaqs.com/boards/929197-resident-evil-5?search=disc 

http://www.fixya.com/support/t1791323-resident_evil_5_freezing_loading_screen

http://futuremark.yougamers.com/forum/showthread.php?124322-RE5-Disc-unreadable

http://www.gamespot.com/resident-evil-5/forum/disc-unreadable-48565056/

http://www.gamespot.com/resident-evil-5/forum/says-disc-is-unreadable-when-i-try-to-play-mercs-reunion-54620161/

http://www.xbox360achievements.org/forum/showthread.php?t=147392

http://alanatharrington.blogspot.com/2012/01/resident-evil-5-gold-mercenaries.html

http://www.bestve.com/bestbrand/bestbrand-162116.html

http://xboxamerica.com/threads/UNREADABLE-DISC

http://community.futureshop.ca/t5/Microsoft-Xbox-360-Kinect/xbox360-Resident-Evil-Elite-bundle-quot-unreadable-disc-error/td-p/157865

http://forums.xbox.com/gfw/technical_support/f/253/p/95501/534138.aspx

 

Discussion Info


Last updated July 3, 2018 Views 3 Applies to:

Haven't ran into this yet. Good post. At least I know if it happens then I'll know it's not just me.

Ya heh my whole story is i bought a copy preowned on Walmart.com.I wasn't expecting it in perfect condition though really it was all immaculate, pristine. So i got to install it, and it fails at 48% every-time so i go to play it thinking it was a fluke and fail at the load-out screen to chapter 1-1. it hard crashes out saying a disc read error sayings its dirty or damaged.

So i send it back for a return, get what seemed to be another copy and it did the same thing, needless to say i gave a talking to Walmart.com support saying they sent me the same bad copy... So i returned it again, but this time they expedited my copy, AND i signed an agreement online where they'd send their copy before they even got mine. And the copy i got this time was the platinum hits version. It does the EXACT same thing. So I'm pretty sure that second disc i had WASNT the same one.

So in fact, i tried 3 separate copies. And i randomly installed a game to see if it was my xbox and it worked perfectly.

After being frustrated i went on a research spree, and came up with many many instances of the same symptoms.

My theory is the new XBG3 update is what caused this, as others have stated their copy ran just fine some time ago(half a year or so) and then sudden has these symptoms. Its clear while there was alot of testing involved with the new update, this one slipped by. I wish i didnt have to buy a Games on Demand version when i essentially paid 20$ already on my unusable copy. 10$ for the game, 2$ shipping, and like 6$ for shipping it back 2 times.

Dor or Do not, There is no Try

I bought the platinum hits version brand new and haven't run into this problem. Great post although, it'll help some people. goooooood job!!