A (slightly different) Citadel Download Issue- love thoughts

Hi all,

Finally broke down and started downloading Citadel last night. Downloaded part one, which took about forty minutes. Went back and downloaded part 2, which took about the same. Shut it down because it was bed time.

Today I went to play and when I logged into the game, it gave me an error message that I had only downloaded part 1 and needed to get part 2. I figured something had gone wrong with the download, so I checked the hard drive. Part 1 downloaded fine, but part two said it was incomplete, with the yellow exclamation point.

I went and hit download again from the menu, to see if it would complete the download. No go. So I went and deleted the incomplete part 2 final and went back to re-download it. Which is when it got weird. 

I've now tried downloading part two about five times, and every time it starts to download, instantly jumps to 5 percent downloaded, and then goes to 100 percent downloaded within ten seconds. But when I go to the harddrive, it shows no sign of part 2 having been downloaded. I've tried restarting a few times; I'm considering deleting part 1 and trying to download both again, but I'm afraid I'll lose that too (not that it's any good without part 2.) 

Any thoughts? Thanks!

 

Discussion Info


Last updated July 3, 2018 Views 0 Applies to:

Others here  forums.xbox.com/.../498078.aspx  have had the same problem, try the solutions that have worked for them, good luck...:-)

A moderator should just pin that thread at this point Arkham.