A Cornered rat Quest GLITCH! help!!

Im on the cornered rat quest and there is a glitch....when i talk to delphine after completeing Diplomatic Utinity or something like that she wont give me the cornered rat quest therefore i cannot go on with the main quest line PLEASE HELP AND BTW I PLAY ON XBOX #^) SO THE PC COMMANDS WONT WORK!!!

 

Discussion Info


Last updated July 4, 2018 Views 7 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

#^) is suppose to say 360

I realize I am very VERY late in responding to this.. but its only because I'm desperately looking for a fix for this same problem. I'm level 37, 60 hours in (I spent a lot of time leveling crafting stuff, sidequesting and overall ADD of the main quest), and I finally decided to continue the main quest.

THE PROBLEM FOR ALL OF YOU IS: You visited Riften before finishing the Diplomatic Immunity quest. For some reason, when you pick up the quest to become a full member of the Thieves guild, which u pretty much get automatically from entering Riften, it bugs the turnin for Diplomatic Immunity. Because, I believe the first person you need to talk to (Brynjolf) once you start "A Cornered Rat", which is the quest after Diplo, is the same guy who you have to talk to to frame some guy for having stolen some other guys necklace.

Now.. I have no clue.. but I'm going to try it because I've been trying to find a fix and I can't.. and don't want to wait for a patch. I saw on this post

forums.steampowered.com/.../t-2231216.html

a guy said he completed the entire thieves guild questline before he even started the main story and had no problems...

So I loaded back to a save before turning in the quest to delphine, and I'm going to try to go become a member of the thieves guild and complete the entire questline. THEN I plan to go back and turn in the quest to Delphine and see if it works. I hope this works for those of you who got screwed with the same thing I did.

didn't work. Did all the quests for thieves guild and can't get to the next step in the main quest.. :/

I have visited Riften multiple times before finishing the main quest "Diplomatic Immunity" and I never got this bug that breaks the quest.  Since this a main quest, I would imagine it would be among the first quest bugs to be fixed.  The good news is that Bethseda will be rolling out patches in January to fix broken quests.  The bad news is that you will have to wait a few more weeks.  Patch 1.4 is already being worked, but it was not stated what will be fixed in it.  It could fix more general bugs or it could be the first quest fixing patch.  We'll have to wait and see.

I have the same problem and it's extremely annoying. I hope they fix this soon. I've just been occupying that time with other side quests

This is the exact problem i've been experiencing. I didn't even realise until after I purposfully went looking for the main quest line. Delphine just goes over a load of rubbish again and again, while Brynyolf just says he's to busy, i hope this gets fixed because otherwise i will end up trading in the game because i can't be bothered to put in another 60+ hours of gameplay to get to where i already was.

I don't know if it helps because I didn't have the same issue but I never got the information from Brynyolf. I went past him and into the sewers as soon as I arrived, a pub/bar in the sewers pointed me in the right direction.

Ok so how do we let Bethesda know of this problem!?!? I am 135 hours in level 45 (almost 46) and I just started back on the main quest. I have finished all of the thieves guild, the dark brotherhood, the champions, the hard college, and the college in winterhold. I'm going to be LIVID if this doesnt get fixed! I have reloaded and done the quest diplomatic immunity evey different way I can and Delphine won't give me the cornered rat quest!  I know where this guy is because of searching through the rat way before,...but that doesn't work either >:O

So, I just got here, too and I can't go farther. I talked to Delphine and she said go find Esbern but the next quest did not appear. I've been to Riften many times, I own a house there but I am a fine upstanding citizen and have not talked to Byrnjolf though I did talk to maul about the gems. I looked at the guide and it says you can skip all that and just go get Esbern but since I don't have the official quest marker he won't talk to me. If I went to Byrnjolf I'm sure he would only want to induct me into his den of iniquity by setting up those two poor fools just trying to make a living. Since it seems to happen a lot and I would have thought it addressed before now I guess I'll wait for the patch. I went back to an earlier save when I hadn't left the dungeon yet to see if that would solve it but I kept getting Malborn killed (I didn't the first time) and kept reloading and then when I gave up and opened the trapdoor the reload screen froze. I think I'm not supposed to do this anymore. BTW I'm level 43 with 180 hours in this character (I piddle around a lot) but I wanted to finish the main quest so I could take a break and get on with some real life stuff that's beginning to pile up.

I am now officially bummed. The main quest is broken for me. I went back to before I escaped the embassy and it still didn't continue. Nothing was right in Riften and the old man still wouldn't talk to me (I hate the Ratway). I did Meridia's quest tonight (that is a really long dungeon) and that's about all I wanted to do other than the main quest. i finished the mages except for the Arniel Gane. I'm not quite up to level for the master quests. Speaking of which, I bought the best fire and ice (other than master) spells, made myself a superpowered necklace to reduce the cost so i could cast them and while my destruct is still only 66 because archery is so much more effective they still should have been better at taking out one miserable fire mage and assassin both of whom ambushed me separately. I can still get even elder dragons with my old spells though my archery is getting good enough to hurt them also. I miss Oblivion's charge in with fireballs blasting. I guess I wait to see if the patch works and just go walkabout again. This is the first quest that broke for me and I'm discouraged.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.