Xbox will connect to network but not internet

Ooookay. It's been a very long day of playing around with my router. I have a Belkin wireless G+MIMO router, F5D9230-4, V. 5000, and a Motorola (Style: MSTATEA) modem. My ISP is Bellsouth/AT&T. I have had Live working since January through this router and internet, with it set on "dynamic." All of a sudden, I received an error message saying that my MTU was insufficient.. so I changed my router to PPPoE so that I could hopefully fix the issue, bridging my modem in the process. Now my xbox will find the network, but cannot connect to the internet. It keeps telling me to do the basic unplug the router and wait 30s fix, which does not work. I've gone through the xbox troubleshooter multiple times, but still no fix. Did a manual DNS, hoping that would fix it, as I had to to get my laptop to connect wirelessly to the network. Still no fix. UPnP is enabled, not sure if that affects this particular issue. I've been trying to reconnect my xbox for about 7 hours straight now, and I am unable to do it on my own. Any help would be greatly appreciated.

 

Question Info


Last updated July 4, 2018 Views 72 Applies to:

So after doing whatever changes you've done on the modem & router your PC still works ok connected to the router yeah? If so is your Xbox wired direct to the router and is it using a static/manual ip address on set to auto?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same router and it's not really helping me. I had to switch to wired connection, because of  either the inefficiency of the router or my xbox picking up the router.  Sorry for asking you a question when you are having problems... But just wondering, do you have connection problems due to your router like me? I seem to disconnect every 5-10 minutes. :(

I'm trying to resolve this problem by seeing if it could possibly be the router.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Shad0wman: My computer works on wireless after I did a manual DNS input for the network on my computer. My xbox is not connected via ethernet because my router is in another room and I don't have a cable long enough to connect it, and quite frankly, after all the time I spent on it I didn't feel like moving it to another room to check if it works when directly connected. I will do that this evening. Right now my xbox is automatic ip address, and automatic DNS. I restored wireless settings back to default on my xbox after trying to change DNS to the same settings I have on my computer and doing the other things that xbox live troubleshooting suggested.

Bomb: It may be the router. I was thinking the same thing myself. When I bought it, it was the best thing I could afford at the time with the most capabilities. I never had a problem with it before now. It doesn't disconnect very often unless I go far away on my laptop, but it might start doing that now, I don't know. Like I said, I had it set to dynamic before because I could get that to work, and as of yesterday it is set to PPPoE. It used to disconnect when I had brighthouse (cable internet) but that is because brighthouse has a shared data stream with anyone/everyone in the neighborhood. I haven't had any problems with connection until yesterday. You might want to check what channel your router is broadcasting on if you live in a heavily populated area, because that can affect connection. When I lived in an apartment, I had to manually set my channel so that I wasn't running on one with common traffic. At my house it's not a problem. Hope that helps. And I have no problem answering questions when I have a problem with something. At the very least, if I can't solve mine maybe I can help you solve yours.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Update: I just moved my xbox so I could connect it via LAN and it WILL connect to Live. It will not even connect to internet wirelessly; just the network, and it has a good signal from my router.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

So wired is fine, but wireless it doesn't. What message does it fail on with wireless when you run the Xbox live test

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

It just says there was a problem connecting, that there is something wrong with my network... Update, though. I was watching a DVD on xbox and it suddenly connected to Live.. I don't know why. Since then, if I start watching a DVD it connects, sometimes it even connects before I have it on. I haven't tried to do anything online yet, though. Any ideas as to why it would suddenly start working?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I think i'm having the same problem.

Since getting Virgin Media with their ridiculas 'Super Hub', XBL has been a nightmare. So now i've opened the ports and manually connected. So it finds my network fine, full bars and everything but no longer connects to the internet.

I'd appreciate some help here too, hopefully someone will have a solution for us :S

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I've got the same problem but with SKY broadband ^^

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.