Xbox stuck on splash screen.

Ya i was exiting IE and put in Halo 4 and i guess it was trying to load it and it froze so i shut it down manually and now it just stays at the initial loading screen when i try to start it up. Ive tried taking out the hard drive and starting it up without it and its the same. ive tried it without my ethernet hooked up and ive tried holding down the sync button while it starts up as well (idk if that even does anything) but nothing changes. im also not able to start it up with my controller and ive even left the system on for multiple hours thinking it might load but nothing happens. help!

 

Question Info


Last updated July 4, 2018 Views 4 Applies to:

Could you try powering off the console,remove the power cable from the console and press the power button several times, reconnect the power cable and try the console again.

Bananas !!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.