Xbox says "Unrecognized Disc"?

So I haven't played my xbox in a week and now decide to play it again. I turn on the xbox and put in the disc (Halo Reach to be specific) and it says "Unrecognized Disc" I thought the disc was a bit dusty after leaving it out of the case for a whole week so I polished it with my shirt and it still did not work. I decided to put a different game in and it still did not work. So I thought some dust may got caught in the tray. I picked most of the dust out of the tray area and tried it again. Nothing. There is no red ring and I can still play arcade games and demos I downloaded. I even tried to vaccum out the other pieces of dust in my xbox and it still did not work. Anyone have any ideas what I should do to fix this problem?

 

Question Info


Last updated July 4, 2018 Views 15 Applies to:

Here are some troubleshooting steps to try and solve your issue.  Good luck.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.