Xbox One won't recognize my external hard drive

So my problem is the following,

yesterday i plugged in my external HDD Lacie 1,5 TB (FAT32) into my Xbox One to watch some video's and it worked perfectly.

However, i had to transfer some large video files (more than 4GB) from my laptop to the HDD, and it appeared that was not possible with Fat32.

So i converted my external HDD from FAT32 to NTFS (with the content still on it) just by using CMD on my laptop. After the converting was complete, i plugged the HDD back into my Xbox One, and now it won't recognize it anymore? I tried all usb ports, tried a different cable but won't help :( i don't know what to do now :(

 

Question Info


Last updated July 4, 2018 Views 30 Applies to:

Try formatting back to FAT32, this is system most commonly recognized by Xbox and Windows.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.