Xbox One Nat Issues

So, over the past couple of days I've been having some serious NAT problems with my Xb1. My gateway information is as follows:

What Country/State/Province do you live in? New Jersey

Modem brand & model number: SMC Networks (brand) SMCD3GNV (model)

Router brand & model number: Same as above

Wired or wireless: Wireless

Things you have tried: Forwarding all Xb1 ports, putting Xb1 in DMZ, enabling UPnP, turned firewall off completely, turned off auto configuration for IPv6 (I wasn't connected via IPv6 previously, just turned it off on a whim) resetting gateway

Is UPnP Enabled? Yes

Do you have a NAT error? If so, what is your NAT type? Moderate/Strict (mostly strict) but it changes from time to time for reasons unknown to myself.

Any Error Codes you encounter: No

Who is your ISP?(Internet Service Provider): Comcast

Basically, I'm lost. I've gone back and forth between thinking it's a gateway issue and thinking its a Microsoft issue. I also started having NAT trouble on my Xbox 360, and tried everything I posted above to attempt to fix it. Nothing worked until I turned off auto config for IPv6 (strange because I'm positive the 360 isn't even compatible with it, but whatever works I guess). Now just having UPnP on is enough to give me an open nat on 360, but I'm still strict/moderate on my One. I would really like to get this issue sorted out, and ideally in a way that allows me to run my XB1 and my 360 at the same and have both NAT's open. Right now when both consoles are on at the same time my 360 has an open NAT while my One has a strict NAT, leading me to believe some Xb1 ports are possibly blocked by my isp. Is this a known issue with Comcast users or something? 

 

Question Info


Last updated July 4, 2018 Views 759 Applies to:

There is a known problem on Comcast in IPv6-enabled markets when the Xbox One is wirelessly connected and the network has an IPv6 IP. See http://www.comcast6.net. If you can disable IPv6 on the SMC, that might help.

As far as for inbound ports that need to be forwarded, both the Xbox 360 and One use the same ports:

Port 88 (UDP)

Port 3074 (UDP and TCP)

(And, reportedly for COD Ghosts, Port 3075 (UDP and TCP))

They are not blocked by Comcast. However, since you have both a 360 and a One, getting Open NAT on both at the same time will require a working UPnP implementation on your router. Not sure about SMC, but many home routers have broken UPnP. implementations...

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Like I said, I turned off IPv6 on my router just in case it was causing an issue with my Xb1, and it's been turned off since. Since I know I can't port forward both devices at the same time my plan was to port forward one, and put the other in the DMZ. So far though, the DMZ hasn't opened my NAT on either my Xb1 or my 360, so there's some issue there. If it's not a known compatibility issue with Comcast, then I guess it must just be a bad gateway. If the DMZ setting doesn't work, UPnP doesn't work, and now my ports aren't getting forwarded correctly I guess something must be wrong internally. I'm maybe 5-10 feet above my router so my connection is excellent and the issue can't be that. I'd like to know if anyone else with the same gateway knows of any weird quirks that might be causing this problem.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Port forwarding one and putting the other in the DMZ won't solve the problem, which is that both the 360 and One use the same port (3074). You can only forward a specific port (3074 in this case) to one internal IP.  DMZ is just another way of forwarding ports--essentially it just forwards to the specified IP ALL ports not otherwise already forwarded via manual setting, UPnP,  etc. (DMZ should be used only as a last resort for that reason).  Thus, when you manually forward a port to one IP, that port will not (cannot) be DMZ forwarded to another IP.  If you can't get UPnP to work, then you could try something I wouldn't normally recommend, which is to manually setup the required port forwards to a specific LAN IP then manually assign that same LAN IP to both your 360 and One. This is not normally a good idea; but as long as you avoid having the 360 and One powered on at the same time, it should work.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I wasn't aware that you couldn't port forward and DMZ at the same time, thanks for the info. And I have actually already tried assigning the 360 and the One the same IP. The problem with this is just like you said, and it was something I had known already. You can't have both systems powered on at the same time which is what I'm trying to avoid anyway. Since about half of my friends don't have an Xb1 (and for the ones that do the party chat system on it is embarrassingly bad) I like to talk to my buddies in a 360 party when I play Xb1 games. Even after they fix the party chat on Xb1 I intend to do this because I still play my 360 most of the time. The only solution then is to get UPnP to work correctly I guess. Or use a wired connection, but I won't be drilling holes in my floor any time soon for obvious reasons.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

There are tons of threads on other forums about your particular modem, with no resolution.  I actually assisted someone with this recently.  It looks like the only way anyone has resolved it with that modem/router combo is to buy their own standalone wireless router and have the SMC set to Gateway mode by Comcast (you can't do it from the SMC's control panel).

If you don't want to have to buy your own wireless router, I recommend calling Comcast and asking them to change out your equipment for something like the Arris modem they use for triple play.  I have one with 3 Xbox Ones and 3 360s, all working perfectly.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Set up a static IP and manual DNS on Xbox ONE. Port forward to that IP. This is the link for guide for your router for specific ports needing opened. portforward.com/.../Xbox_One.htm

Once you've port forwarded. Go back to your Network Settings on Xbox ONE, go to Advanced Settings, Then go to Alternate Mac Address, click it, click clear, then click restart. Once its restarted your NAT should be opened up.

Also, if you're resorting to port forwarding. You most likely won't be able to have both operating at the same time with an Open NAT. Its unfortunate I know but, if it makes you feel any better I have the same issue while running both at the same time. Only one can have the Open NAT at a time.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I hate to be the bearer of bad news but the only way to get multiple consoles online at the same time (with open NAT) is to use a router that has a better implementation of PAT then your current one does. As stated earlier in the thread both the One and the 360 both use port 3074. PAT allows devices on your network to "share" the port. It is a lot of work at first but you would need to swap your gateway for a modem from Comcast(they can do it at a service center) and then to purchase a router that can support multiple consoles. You will want to search the forums and check the Networking Hardware Information forum for devices listed as able to do it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.