Xbox One Bug: Switching HDMI sources

Hi Xbox, and community :)

So this bug has been annoying me since Day-One, but even more so since the console update as it happens 100% of the time now.

Wondering if anyone else has the same problem, and also if the Xbox team know about its switching issues?

 

Basically, I have my SKY STB Box plugged into my Xbox One which is then plugged into a Onkyo Receiver (TX-NR515). I then have everything else plugged in here such as my HTPC, Raspberry Pi, PS3, etc....Its awesome having an HDMI receiver as I can just switch between everything quite seemless. Sounds good in theory anyway...

The frustrating part, is that if I switch my Onkyo Receiver to any other video source such as PS3, or my HTPC, then switch back to the XBOX One, I either cant get the signal for the STB, or Xbox One just wont give a signal what so ever

It keeps saying there is no signal, then it *might* have a signal for 1-2 seconds, then bugs out again. 

Switching sources doesnt help.

Hard restarting the SKY STB doesnt help. 

Hard restarting the Onkyo Receiver doesnt help. 

Only restarting the Xbox works. This leads me to believe that it is a bug with the Xbox One, that it cannot recover that signal properly for whatever reason. 

The Xbox functions just fine when this happens, apart from I cant restore the signal from the STB. I can also just use the voice commands to shut it down and restart - I have it integrated with my TV / Receiver / STB to shutdown all at the same time, and this also works just fine. 

NB: This only happens when the Xbox One is connected in. I've also been using the official HDMI cable that came with my One Day, and tried a second brand new HDMI 1.4 cable also. 

Heres a demo of what it looks like http://www.youtube.com/watch?v=4ESRveG_Dpc

 

Question Info


Last updated July 4, 2018 Views 169 Applies to:

Wonder if it is your receiver losing the hand shake?  My set up is similar, except I am using a Direct TV Genie (main dvr) and my receiver is a Yamaha RX-V573 with latest firmware.

Is your Onkyo firmware able to be updated?

I have my PS3, PS4  plugged into the receiver as well.  I can switch back and forth between the inputs with no problems.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

My firmware can be updated, but it doesnt have any further updates.

The receiver switches fine between every other source, as i've had it for around 18 months and its been perfectly fine (I have HTPC, PS3, Raspberry Pi, X360 plugged into it) switching between all other sources. It's only the Xbox One.

Also the odd thing is that the issue in the video I posted, where it doesnt load the XBO's signal at all has only started recently, What would happen previously, is that I would switch back to the Xbox, and I could see the homescreen and play games etc...just couldn't view the TV (SKY STB) wether I switched to the app, or snapped it.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Just for the heck of it try this:With the console on, press and hold the power button on the console for 5-8 seconds until it shuts off.  Unplug the power supply, wait about 30 seconds and then plug it in and reboot.  You should see the green splash screen upon reboot.  It may take a minute to boot all the way to the home screen.  If you did not see the green Xbox splash screen, please redo it.  then see if it makes any difference on your switching

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

The Xbox gets a proper restart quite often, as I have to switch it to US Region to use the smart voice features, and then switch it back to my region to make a Shop purchase. This does a full restart with the Green Xbox splash screen each time. Still suffer the same issue regardless unfortunately.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.