Xbox One Blu-ray Player - Dark Knight Box Set - Odd Results

Got a box set of the Dark Knight Trilogy with some special features discs.

There are 6 discs in total in the box set, 4 play on the XBOX One, 2 don't..

The 2 that don't work, happen to be The actual Films (Begins and Rises).

Super annoying. So I took the discs to a couple places and had them tested. They work on other Blu-ray players.

Tried them back on my system and they just  get as far as the Blu-ray screen with the light blue background and the Blu-ray symbol in the middle with the loading "spiral" but never play. 

Dodgy Xbox Disc Reader? or Xbox One physically incapable of playing them? Wait for a patch? Return it?  Ideas would be apreicated.

 

Discussion Info


Last updated July 4, 2018 Views 1 Applies to:

Delete and re-install the blu-ray app?? Hard reset of the console??

Do the two movies have Ultraviolet?

Check your video settings.  Make sure your playback settings on the Xbox One are set at 24 Hz.  I have not attempted to watch these movies on my Xbox One yet but the ones I have watched have worked fine.  If that does not work, then I would try deleting the Blu Ray software and re installing it.  If that does not fix the problem then you may have a problem with your disc reader lens.

If 4 of the 6 disc work I wouldn't think it would be an app or drive issue.

I know there used to be an issue with some of the off brand Blu Players having a problem with Ultraviolet. If I remember correctly when you insert a disc with Ultraviolet a window pops up. connects you to the internet and you register the disc for the digital version. With certain brands the window would never pop and the system would hang.

Has anyone played a disc with Ultraviolet and have it work?

@Burnin TODI - I didn't think to try deleting and reinstalling the app, can give that a crack tonight.

@Randver - Not Ultraviolet

@FullHornet - I will suss the playback settings before I uninstall it

Thanks for suggestions

The app is pretty buggy,  exspecially on dvd movies.  

I have the same box set at home. I only tried one of the discs and it worked fine.  I will check the other discs when I get off work tonight and let you know my results.

Some good news.

Enabling the 24hz feature for Blu-ray playback didn't amend the defect, but uninstalling the Blu-ray app and then restarting the xbox, then re-downloading the app seems to have improved things.

Side note: Load time was peculiar, After inserting the previously unworkable disc it took 1:16 before it recognised it was even in the tray, then it loaded to a black screen where it was essentially paused? but when I pressed the right trigger for fast forward it began to play content. Movie Plays, no complaints here. Just in comparison to the other discs which essentially load instantly after being inserted it just seems slightly odd, but none the less I am just stoked I don't have to return it and wait for repairs.  

Have the same set and they work me for me on the X1...but i heard the app is buggy for some people.

My Avatar blu-ray  doesn't work on the xb1, it plays on my Samsung with no issues.  I haven't had any issues with my other Blu-ray's.   I'll try re-installing it tonight.