Xbox One audio adaptor - problems echoes

using the new audio adaptor with my turtle beach headset keep getting echo on chat and game audio  - anyone else having problems?

 

Discussion Info


Last updated July 4, 2018 Views 23 Applies to:

Does your Turtle Beach headset have the talkback feature? I feel that this could perhaps be a conflicting issue. Failing that I'd possibly suggest checking your connection strength. They're just guesses though.

Not those problems but doesn't surprise me one bit...these WAY overpriced chat adapters are garbage and are limiting this system currently for having a truly wireless system. Absolutely STUPID for microsoft to go this route with their proprietary hardware.  These chat adapters have been nothing short of a big pain in the rear.  They have been the cause of my distortion through 3 different headsets.  Faulty p.o.s's are these chat adapters and shame on MS for implementing them and then overcharging for a $5 adapter.  $29.99 pffffft price gouging at an extreme.

My friends and I quit using ours because they are junk. One of us has a Turtle Beach set, the other two of us have Tritton 720+. All of us have the same problems of static/humming/buzzing and we can hear noise whenever people hold down the trigger buttons to fire. They're useless. We went back to using the Kinect to chat. Tons of people are having this problem. Just Google it or use Amazon's reviews to search.

I have the same issue, Unless I turn down the chat volume on the controller, then it's fine, but I can't hear anyone talking

X41 user, but I imagine the problem will work for you if ur a turtlebeach owner at least.

 

NOTE: The Xbox One System Update released on 3/4/14 enabled Dolby Digital 5.1 on the Xbox One. If you do not see a Dolby Digital 5.1 option under the Optical Output sound settings, make sure your console is fully up to date.

To configure the Sound Settings:

1. Go to the Home Screen

2. Press the Menu Button on the Xbox One Controller

3. Go to Settings > Display and Sound > Optical Audio, Select 'Bitstream Out'

4. Go to Settings > Display and Sound > Bitstream Format, Select 'Dolby Digital'

http://www.turtlebeach.com/support/entry/830517602/

Also be sure to uncheck "Use Kinect for Chat" in the Kinect settings. This has helped a lot of users with the adapter.

-Jim