Xbox no longer recognizes my external drive with all my games.

I have NEVER had this many issues.  Ever since the new Windows 10 update there has been issue after issue.  First my games would crash or get errors.  Then it would not load the TV app so I could not watch tv.  Now I get up, on Vacation, ready to play my games, and NONE of my games are showing up.  I have NEVER had this issue.  I have a 3TB WD External drive and I never changed anything.  I'm seeing that others are having this issue as well.  Are they not checking these things before they put them out?  What the heck!  Anybody know how to solve this issue? As others said, I have way too many games to try to redownload them and more than what would work on my Internal Xbox HD.

 

Question Info


Last updated July 4, 2018 Views 10 Applies to:

Try disconnecting you HDD and then doing a hard reset on your HDD let it set for a couple of minutes reconnect your HDD then power up your console back up and see if the drive is found.  Let us know if it works for you.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there D9Cyph,

I'd connect the drive to a PC that can recognize it and run a diagnostic tool to check if the drive is performing properly. I would run WD Data Lifeguard Diagnostic tool and see if the WD external drive passes both the quick and the extended test to be on the safe side that the drive is healthy. Here's a link to the tool: products.wdc.com/.../kb.ashx

I'd also follow Genesis's suggestion and see if that helps. I'd also contact MS's support and see if the guys can offer a solution ot the problem.

Captain_WD.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I also have a WD 3TB drive; a Mybook. Mine works relatively fine except for an annoying message that pops up upon booting up saying the drive us ready for use. Have you tried a different usb port?

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.