Xbox Live, Language and Locale stuck in Japanese

My Xbox account is stuck in Japanese language and and locale, when i go to add a credit card on there I type in my zip code and it asks for a postal address, and when I click on state its called Prefecture and all of the option are in Japanese. When it says how much things cost, it is in Yen. I have from the United States, and I have tried changing everything to fix this. I tried changing locale and language settings to United States and English again. i tried deleting my account and recovering and I don't know what else to do, so if anyone has any idea on how to fix this please help.

 

Question Info


Last updated July 5, 2018 Views 147 Applies to:

here Go to here and change your region: support.xbox.com/.../change-region

and fallow the steps

hope that helps:)

Computer person... also a Mopar technician.
CEO of Independent LLC

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

where are the steps? that page just seemed to explain what would happen if I changed it, couldn't find the actual steps

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

OK found the link (the hyperlink did not stand out from the text). however it didn't work. I don't think my region is wrong, just my locale. I found the spot where I'm supposed to be able to to change it (console settings) but it won't change from Japan

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

just learned that you need family settings off. whew

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.