Xbox Live keeps disconnecting after sign-in

Ever since last Friday, Xbox Live's been disconnecting me almost immediately after I sign into Xbox Live on my console. I was playing Dead Island and I decided to ignore the update for it so, I ended up playing it offline. When I stopped playing, I exited to the main menu and turned off the console while at the main menu and still offline. The next day, I turn on my console, sign into Xbox Live, and after about ten seconds, I've been disconnected. Whenever I'm idle at the dashboard, I get disconnected. Starting up a game signs me back into Xbox Live but, after a few seconds, I'm disconnected again. I've tried everything I could. Unplugged and replugged the console; resetting my router; disconnecting & reconnecting my console's connection to the router; etc. Everything works fine; the internet, the router, etc. Nothing's busted or anything. I recovered my profile onto a different Xbox and everything's fine on that console just not on my own console. So, I've come to believe that my console is the problem.

If anyone has any other ideas or solutions, please help! It's been nearly a week and I've been missing out on playing GOW3 with friends and playing the BF3 beta!

p.s. my console is an Xbox 360 S

 

Question Info


Last updated July 4, 2018 Views 10 Applies to:

United States

Motorola SBV5120 SURFboard Cable Modem

NETGEAR WNR3500L

Wireless connection

Password protected

Internal Xbox 360 S adapter

UPnP is enabled

NAT Type is Open

Optimum Wi Fi

Error Codes after testing Xbox Live connection:

W: 0000 - 0021

X: 0000 - F001

Y: 20A8 - 4840

Z: 0000 - 0000

ID: FFFF - FFFF

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey, we need a bit more detailed info if possible. Could you start with the "Start Here" post and provide the info it requests? forums.xbox.com/.../9.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.