Xbox Live is acting crappy again.

Hello, i am having trouble connecting to Xbox Live. every time i try to sign my Gold account in, it says my MTU is too low. this happened last week but it was your servers fault. it worked last night, but now its saying the same thing again this week. the status for XBL says its up and running, but i can't sign ANY profiles into Live. this is the second time this has happened in 2 weeks. also, i have frequent dis-connects. a real issue when playing online. thank you for reading, and for any help on whats up.

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

well XBL is up and running have you checked your connection speed, or your ISP could be doing some work and that can disconnect you from the internet at random intervals.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Depends of you are using a wireless connection or a wired connection. If wireless,  your router may not be able to handle xbox live.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

also as the lat user posted with the wireless connection check your NAT that can affect it to if you dont know how to check your NAT you just have to test your xbox live connection and after you do that if your NAT is closed a MSG will pop up telling you if nothing is wrong then nothing will pop up

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.