Xbox Live bad connection - Can't join friends parties and games.

Recently I haven't been able to connect to some of my friends parties on XBL, although I can connect to other people's parties who doesn't live in my neighbourhood. I've had this problem before but it usually dissapeared after a day or two, now this problem has been lasting for a week.

I've also had a terrible connection on MW2 when I'm trying to find games, it usually takes up to 1-2 minutes to find a game and sometimes I get kicked out of the lobby for bad connection.

It also takes quite a long time to join someone's party, about 15 seconds. What should I do? My NAT is open, I've tried to port forward, nothing is working!

Please take notice this just happened randomly it has been working fine but about 5 days ago this started... I want to be able to talk to my friends and play with them!

 

Question Info


Last updated July 4, 2018 Views 0 Applies to:

Hey there - can you review the START HERE sticky, try it's suggestions, and if they do not work, post the requested information here? forums.xbox.com/.../9.aspx

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Are you getting connected by Wireless? Sometimes signal could be blocked or interferred and it causes lag. Try by using an ethernet cable, if not, You shold monitor your network speed and contact your ISP

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Using wired.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey Exist - could you post the information requested by the START HERE sticky mentioned above? That would really help us narrow down your issue. :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Did you check your NAT settings they could be the problem or if its a connection problem try putting your xbox closer to your modem/router

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I am having the same problem right now. Wired as well and no error message when I do the Xbox live Connection Test. Although, when I first start up my console, It won't connect me to live. I have to test the connection first(Works on the first try everytime) then it will let me sign into Live

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

This worked for me. Go to your system settings, then memory, press "Y" and delete the System Cache (it deletes all recent updates). So after you have done that, start up MW3 and it will have you update the game.

I guess its something to do with one of the original updates for the game.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.