Xbox keeps disconnecting from Xbox Live when playing singleplayer or local co-op (Getting really frustrated)

As the title states, my Xbox keeps disconnecting from Xbox Live when playing singleplayer or local co-op (whenever I am playing online it never disconnects). I posted in another thread and was asked to create my own. This has been happening for almost two weeks now and I am getting frustrated, I was hoping it would go away on its own. I know it isn't a router issue, since plugging straight in doesn't work either, plus I have had friends playing on the same router and I would disconnect, but they wouldn't.

What Country/State/Province do you live in? United States, Utah
Modem brand & model number:
Not sure
Router brand & model number:
D-Link DIR 655

Things you have tried: 

I have tried: Resetting router, Deleting cache, Deleting "corrupt files" then deleting my profile and redownloading it, Resetting my network settings to factory default


Is UPnP Enabled? Yes/no/Unknown
Unknown



After you run "Test Xbox LIVE connection" press “Y” for "More Info”. In the pop-up that appears, what are the following values, if shown? (If a value below does not appear for you, just leave it blank.)
W:
0000-000B
X:
0000-F001
Y:
20A8-4840
Z:
0000-0000
ID:
FFFF-FFFF
L:
0015-10F0
Q:
8015-1004
T:
Wired
D:
192.168.0.100/255.255.255.0
S:
192.168.0.1
C:
192.168.0.1/0.0.0.0

 

Question Info


Last updated July 4, 2018 Views 128 Applies to:

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.

Greetings, BlinkFandangoII! Very sorry to hear about your situation. Let's see what we can do to get this sorted out.
 

First, it looks like there's some uncertainty as to whether UPnP is enabled for your router. Can you please try enabling it and see if that makes a difference in your ability to connect? You can find steps for how to do this here: www.dlink.com/.../default.aspx.

Give it a shot and keep me posted! Standing by.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I checked my router, uPnP is enabled. Also, I have checked with Xbox Live support three times now. They have told me to remove my hard drive and put it back in (in case it wasn't seated properly), they've told me to change my IP settings to manual. I have tried everything I can think of, nothing is working. This is driving me crazy! It doesn't make any sense! Please help.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey there Blink! You mention that you are using manual IP settings, what about port forwarding? If you have enabled this, try turning UPnP off and then try again. Alternatively you could disable port forwarding and enable UPnP. Let me know if you have tried this and if it helps. Thanks!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, I'll try it when I get home tonight and let you know if it works.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Thanks, BlinkFandangoII. Keep us posted! :)

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

I have the same router.  Make sure Under Advanced / QOS Engine WAN traffic shaping is NOT selected and QOS Enable QOS Engine is NOT enabled.

My hardware version is A2 and the firmware version is 1.34NA

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

LOL I love playing around with Routers and settings. I implimented  BlinkFandangoII issue on my very own same modem and xbox and I un-enabled UPnP then saved settings then re-enabled UPnP. Then I went to my xbox and MANUALLY entered an IP address, then went to my router settings and matched the IP address and it worked like a BOSS! Verified!

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Hey guys, sorry for the delay, Here's a quick update.

1. I turned of QOS Engine Traffic Shaping and QOS Engine, but I still get disconnected.

2. I made sure UPnP was enabled and disabled port-forwarding, still got disconnected.

At this point I am sure that the problem is with my Xbox and not my router or connection. I will know for sure tomorrow, I am taking my Xbox to a friend's house tomorrow to see if I have the same problem. If any one else has any other suggestions, they would be most welcome.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Quick update: I tried logging into another account to see if the problem was with my account, but it still disconnected. At this point it is either my network (which is highly unlikely, because, as I have already stated, I have had multiple friends on the same router and I am the only one getting disconnected) or my Xbox (though I'm not sure why it stays connected over Xbox Live when I play multiplayer online).

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

Another quick update: I just tried pinging my Xbox from my laptop and the request kept timing out. Is that normal? Also, I have noticed that downloading something to my Xbox will stop it from disconnecting from Xbox Live.

Did this solve your problem?

Sorry this didn't help.

Great! Thanks for marking this as the answer.

How satisfied are you with this reply?

Thanks for your feedback, it helps us improve the site.

How satisfied are you with this response?

Thanks for your feedback.

* Please try a lower page number.

* Please enter only numbers.

* Please try a lower page number.

* Please enter only numbers.